# 视图

> For the complete documentation index, see [llms.txt](https://www.jetbrains.com.cn/help/idea/llms.txt).

视图 是一个通常表示数据库查询的数据库对象，可以像普通表一样使用。 欲了解更多信息，请参阅您的 DBMS 文档。

当您在   数据库  工具窗口（  `视图 | 工具窗口 |   数据库` ）中双击视图时，该视图将在   表  视图的编辑器中打开。 如需了解更多有关视图的信息，请参阅 [查看数据](tables-view-data.html)。

> **Note:**
> 数据库表格数据仅在 Ultimate 订阅中可用。 如果没有订阅，点击两次会打开表 DDL 定义。

视图（ ![视图](https://resources.jetbrains.com.cn/help/img/idea/2026.3/app-client.expui.gutter.dataSchema.svg)）可以在   数据库  工具窗口中找到。

* 有关其他节点和对象图标的参考信息，请参阅 [数据库工具窗口](database-tool-window.html) 主题中的 [数据源及其元素](database-tool-window.html#icons-for-data-sources-and-their-elements) 章节。

* 使用 [视图选项](database-tool-window.html#view_options) 菜单中的树对象视图选项隐藏、排序、过滤和分组树对象。

![数据库中的视图](https://resources.jetbrains.com.cn/help/img/idea/2026.3/database_object_view.png)

Procedure: 创建视图

1. 在   数据库   工具窗口中，展开数据源树直到架构节点。

2. 右键点击架构节点并选择  `新建 | 视图` 。

3. 在打开的   创建  对话框中，在   名称  字段中输入视图的名称。

4. 在   源文本  窗格中输入语句。

5. 在   预览   窗格中，您可以查看和更改生成的 SQL 代码。

6. 点击   OK  以添加您的视图。

> **Note:**
> 可用字段和选项取决于 DBMS。 有关更多详细信息，请参阅 DBMS 的官方文档。

![创建视图](https://resources.jetbrains.com.cn/help/img/idea/2026.3/db_create_view.png)

Procedure: 修改视图

1. 在   数据库   工具窗口中，右键点击视图，然后选择  `导航 | 转到 DDL` 。 或者，按 `Ctrl+B` (Windows), `⌘ B` (macOS), `⌘ B` (IntelliJ IDEA Classic (macOS)), `⌘ B` (macOS System Shortcuts), `Ctrl+B` (XWin), `Ctrl+B` (GNOME), `Ctrl+B` (KDE), `Ctrl+Alt+G` (Emacs), `F12` (Sublime Text), `F12` (Sublime Text (macOS)), `F12` (Visual Studio), `F12` (Visual Studio (macOS)), `Ctrl+B` (NetBeans), `F3` (Eclipse), `F3` (Eclipse (macOS))。

2. 在打开的 DDL 编辑器中，更改视图的源代码。

![使用 DDL 编辑器修改视图](https://resources.jetbrains.com.cn/help/img/idea/2026.3/modify_view_ddl_editor.png)

3. 点击   提交   按钮（ ![提交按钮](https://resources.jetbrains.com.cn/help/img/idea/2026.3/database-plugin.icons.submitDB.svg)）。 或者，按 `Ctrl+K` (Windows), `⌘ K` (macOS), `⌘ K` (IntelliJ IDEA Classic (macOS)), `⌘ K` (macOS System Shortcuts), `Ctrl+K` (XWin), `Ctrl+K` (GNOME), `Ctrl+K` (KDE), `Ctrl+K` (Emacs), `Ctrl+K` (Sublime Text), `Ctrl+K` (Sublime Text (macOS)), `Ctrl+Alt+K` (Visual Studio), `⌘ ⌥ ⇧ K` (Visual Studio (macOS)), `Ctrl+K` (NetBeans), `Ctrl+K` (Eclipse), `Ctrl+K` (Eclipse (macOS))。

Procedure: 虚拟视图

* 如果您需要经常运行相同的语句并查看其结果集，请考虑使用虚拟视图，即 IntelliJ IDEA 的虚拟对象。 有关虚拟视图的更多信息，请参阅 [虚拟视图](virtual-views.html)。

![虚拟视图](https://resources.jetbrains.com.cn/help/img/idea/2026.3/db_virtual_view.png)

### 参考

[数据编辑器和查看器](data-editor-and-viewer.html#reference) [创建和修改对话框](create-and-modify-dialogs.html#views) [栏目可能的图标组合](database-tool-window.html#possible-icon-combinations-for-columns) [数据源及其元素](database-tool-window.html#icons-for-data-sources-and-their-elements)

### 相关

[查看数据](tables-view-data.html)

### 工具 Windows

[数据库工具窗口](database-tool-window.html)

### 导航

### 语言和框架特定指南

[数据库工具和 SQL](relational-databases.html)

