# 列

> For the complete documentation index, see [llms.txt](https://www.jetbrains.com.cn/help/idea/llms.txt).

列  是表存储的数据项。 这些数据属于特定类型。 一列可以包含文本、数字或操作系统中的文件指针。 有些关系数据库系统允许列包含更复杂的数据类型，如整个文档、图像或视频片段。

列 ( ![列](https://resources.jetbrains.com.cn/help/img/idea/2026.3/database-plugin.icons.expui.column.svg) ) 可以在   数据库   工具窗口中找到。

* 有关其他节点和对象图标的参考信息，请参阅 [数据库工具窗口](database-tool-window.html) 主题中的 [数据源及其元素](database-tool-window.html#icons-for-data-sources-and-their-elements) 章节。

* 关于表列图标，请参阅 [栏目可能的图标组合](database-tool-window.html#possible-icon-combinations-for-columns) 章节。

* 使用 [视图选项](database-tool-window.html#view_options) 菜单中的树对象视图选项隐藏、排序、过滤和分组树对象。

![数据库中的列](https://resources.jetbrains.com.cn/help/img/idea/2026.3/database_object_column.png)

Procedure: 添加列

1. 在   数据库   工具窗口中，展开数据源树，直到表节点。

2. 右键点击表节点并选择  `新建 | 列` 。

3. 在打开的   修改   对话框中，在   名称   字段中输入列的名称。

4. 在   预览   窗格中，您可以查看和更改生成的 SQL 代码。

5. 点击   OK   以添加列。

> **Note:**
> 可用字段和选项取决于 DBMS。 有关更多详细信息，请参阅 DBMS 的官方文档。

![添加列](https://resources.jetbrains.com.cn/help/img/idea/2026.3/db_add_new_column.png)

Procedure: 删除列

1. 右键点击列并选择  `对象操作 | 删除…` 。 或者按 `Delete` (Windows), `⌦` (macOS), `⌦` (IntelliJ IDEA Classic (macOS)), `⌦` (macOS System Shortcuts), `Delete` (XWin), `Delete` (GNOME), `Delete` (KDE), `Delete` (Emacs), `Delete` (Sublime Text), `⌦` (Sublime Text (macOS)), `Delete` (Visual Studio), `⌦` (Visual Studio (macOS)), `Delete` (NetBeans), `Delete` (Eclipse), `⌦` (Eclipse (macOS))。

2. 点击   OK   以保存您的更改并关闭对话框。

有关对话框选项的更多信息，请参阅 [确认删除对话框](confirm-drop-dialog.html)。

![删除列](https://resources.jetbrains.com.cn/help/img/idea/2026.3/db_delete_column.png)

> **Note:**
> SQLite 支持有限的  `ALTER TABLE`  命令子集。 在 SQLite 中，您可以重命名表，重命名表中的列，并向现有表中添加新列。 有关 SQLite 中命令的更多信息，请参阅 [官方 SQLite 文档](https://www.sqlite.org/lang_altertable.html)。
>
>
>
> 要在 SQLite 中删除列，请右键点击表并选择   修改表格  。 在   修改  对话框中，选择您要删除的列并点击   移除  按钮( !["移除"按钮](https://resources.jetbrains.com.cn/help/img/idea/2026.3/app.expui.general.remove.svg))。   修改   操作会重新创建一个不包含已删除列的表。

Procedure: 修改列

从 IntelliJ IDEA 2022.1 开始，您可以更改列的数据库特定参数。 IDE 会根据内省期间收到的属性，自动为   修改   对话框生成字段。 例如，在 PostgreSQL 中使用此对话框，可以添加和编辑列检查约束。

1. 在   数据库   工具窗口中，右键点击列并选择   修改列  。

2. 在   修改   对话框中，指定所需的对象设置。

> **Note:**
> 列设置取决于数据库供应商。 例如，   自动递增   复选框仅适用于 SQLite、MySQL 以及其他允许将其用于整数数据类型主键列的供应商。

3. 点击   OK   保存更改。

Procedure: 重新排序列

* 要重新排序列，请拖动标题行中的相应单元格。

[Video](https://resources.jetbrains.com.cn/help/img/idea/2026.3/db_reorder_columns_by_dragging.mp4)

Procedure: 隐藏列

* 要隐藏列，请右键点击相应的标题单元格并选择   隐藏列  。

或者，您可以右键点击标题行中的任何单元格，然后选择   显示列列表   `Ctrl+F12` (Windows), `⌘ F12` (macOS), `⌘ F12` (IntelliJ IDEA Classic (macOS)), `⌘ ⇧ 7` (macOS System Shortcuts), `Ctrl+F12` (XWin), `Ctrl+F12` (GNOME), `Ctrl+0` (KDE), `Ctrl+F12` (Emacs), `Ctrl+R` (Sublime Text), `⌘ R` (Sublime Text (macOS)), `Alt+\` (Visual Studio), `⌥ \` (Visual Studio (macOS)), `Ctrl+F12` (NetBeans), `Ctrl+F3` (Eclipse), `⌘ O` (Eclipse (macOS))。 在列列表弹出窗口中，选择列名并按 `Space` (Windows), `Space` (macOS), `Space` (IntelliJ IDEA Classic (macOS)), `Space` (macOS System Shortcuts), `Space` (XWin), `Space` (GNOME), `Space` (KDE), `Space` (Emacs), `Space` (Sublime Text), `Space` (Sublime Text (macOS)), `Space` (Visual Studio), `Space` (Visual Studio (macOS)), `Space` (NetBeans), `Space` (Eclipse), `Space` (Eclipse (macOS))。 您可以隐藏所有列。 要搜索列列表，请在   显示列列表   窗口中开始输入列名称。

![隐藏列](https://resources.jetbrains.com.cn/help/img/idea/2026.3/db_hide_columns.png)

Procedure: 显示列

1. 右键点击标题行中的任何一个单元格，然后选择   显示列列表  。 或者按 `Ctrl+F12` (Windows), `⌘ F12` (macOS), `⌘ F12` (IntelliJ IDEA Classic (macOS)), `⌘ ⇧ 7` (macOS System Shortcuts), `Ctrl+F12` (XWin), `Ctrl+F12` (GNOME), `Ctrl+0` (KDE), `Ctrl+F12` (Emacs), `Ctrl+R` (Sublime Text), `⌘ R` (Sublime Text (macOS)), `Alt+\` (Visual Studio), `⌥ \` (Visual Studio (macOS)), `Ctrl+F12` (NetBeans), `Ctrl+F3` (Eclipse), `⌘ O` (Eclipse (macOS))。

2. 选择隐藏的列（删除线列名），然后按 `Space` (Windows), `Space` (macOS), `Space` (IntelliJ IDEA Classic (macOS)), `Space` (macOS System Shortcuts), `Space` (XWin), `Space` (GNOME), `Space` (KDE), `Space` (Emacs), `Space` (Sublime Text), `Space` (Sublime Text (macOS)), `Space` (Visual Studio), `Space` (Visual Studio (macOS)), `Space` (NetBeans), `Space` (Eclipse), `Space` (Eclipse (macOS))。

![显示一列](https://resources.jetbrains.com.cn/help/img/idea/2026.3/db_show_columns.png)

> **Tip:**
> 您可以在   结构   工具窗口 (  `视图 | Tool Windows | 结构体窗格结构体结构结构结构` ) 中查看整个表结构。   结构  工具窗口显示所有列。

Procedure: 将表格视图重置为初始状态

* 点击设置图标（ ![设置图标](https://resources.jetbrains.com.cn/help/img/idea/2026.3/app.expui.general.settings.svg)）并选择   重置视图  。 结果，数据变得无序，列按最初定义的顺序显示，并且所有列都显示出来。

![恢复初始表格视图](https://resources.jetbrains.com.cn/help/img/idea/2026.3/db_reset_table_view.png)

Procedure: 为列注入一种语言

* 您可以为整个列分配 HTML、CSS、XML、RegExp 或任何其他形式语言。 因此，当您的单元格内有属于该列的代码时，您可以使用代码生成、代码补全和其他 IDE 功能。

要为整列注入语言，请右键点击相应的表头单元格，然后选择   设置高亮语言  。 在支持的语言列表中，选择您要注入的语言。

![为列注入一种语言](https://resources.jetbrains.com.cn/help/img/idea/2026.3/db_inject_language_column.png)

Procedure: 更改列宽

* 将文本光标放在两列之间，使其变为调整大小模式。 将其拖动到首选位置。

## 与数据协作

要了解如何处理列数据，请参阅 [数据编辑器和查看器](data-editor-and-viewer.html) 部分的主题：

1.

[排序数据](tables-sort.html)

您可以通过点击列标题或在相应字段中输入排序查询来对数据进行排序。 默认情况下，每次您排序数据时，IntelliJ IDEA 会向数据库发送一个新的  `排序依据` 查询。 您还可以更改设置并在客户端对数据进行排序。

[Video](https://resources.jetbrains.com.cn/help/img/idea/2026.3/db_stacked_sorting.mp4)

2.

[使用筛选器筛选数据](tables-filter.html)

过滤数据的方式如下：

* 指定筛选条件。

* 在表格上运行搜索。

* 在相应字段中输入筛选查询。

![用于排序的 WHERE 和 ORDER BY 字段](https://resources.jetbrains.com.cn/help/img/idea/2026.3/db_where_and_order_by_fields_for_sorting.png)

## 效率提示

Procedure: 将列名拖动到您的代码中

* 在   数据库   工具窗口中，选择任意数据库对象并将其拖动到代码中。

![将列名拖动到您的代码中](https://resources.jetbrains.com.cn/help/img/idea/2026.3/drag_database_objects_to_code.png)

### 参考

[创建和修改对话框](create-and-modify-dialogs.html#objects_editor) [栏目可能的图标组合](database-tool-window.html#possible-icon-combinations-for-columns)

### 相关

[主键](primary-keys.html) [查看数据](tables-view-data.html)

### 工具 Windows

[数据库工具窗口](database-tool-window.html)

### 导航

### 语言和框架特定指南

[数据库工具和 SQL](relational-databases.html)

