# Data editor and viewer

Procedure: Enable the Database Tools and SQL plugin

This functionality relies on the  Database Tools and SQL plugin, which  is bundled and enabled in IntelliJ IDEA   by default. If the relevant features are not available, make sure that you did not disable the plugin.

> **Note:**
> Database Tools and SQL functionality support is limited in IntelliJ IDEA without the Ultimate subscription.

1. Press `Ctrl+Alt+S` (Windows), `⌘ Comma` (macOS), `⌘ Comma` (IntelliJ IDEA Classic (macOS)), `⌘ Comma` (macOS System Shortcuts), `Ctrl+Alt+S` (XWin), `Ctrl+Alt+S` (GNOME), `Ctrl+Alt+S` (KDE), `Ctrl+Alt+S` (Emacs), `Ctrl+Alt+S` (Sublime Text), `⌘ Comma` (Sublime Text (macOS)), `Ctrl+Alt+S` (NetBeans), `Ctrl+Alt+S` (Visual Studio), `⌘ Comma` (Visual Studio (macOS)), `Ctrl+Alt+S` (Eclipse), `⌘ Comma` (Eclipse (macOS)) to open settings and then select `Plugins`.

2. Open the Installed tab, find the Database Tools and SQL plugin, and select the checkbox next to the plugin name.

## Overview

The data editor and viewer, or data editor, provides a user interface for working with data. In the data editor, you can sort, filter, add, edit, and remove the data as well as perform other associated tasks.

In IntelliJ IDEA, the data editor and viewer lets you work with [database object data](#open_database_object_data), [query result sets](#view_query_result_set), and also [User files data](#view_user_files_data_as_a_table).

Database object data:

![Database object data in data editor](https://resources.jetbrains.com.cn/help/img/idea/2026.2/data_editor_db_object_data_intro.png)

1. [Toolbar.](#toolbar_controls)

2. [Filtering](tables-filter.html#filtering_sorting_data) and [sorting](tables-sort.html#filtering_sorting_data) queries pane.

3. The database object data in a [Table view](tables-view-data.html#data_view_modes_list).

For more information about   Database   tool window , refer to [Database tool window](database-tool-window.html).

Query result set: Services tool window:

1. [Toolbar.](#toolbar_controls)

2. The query result set in a [Table view](tables-view-data.html#data_view_modes_list).

For more information about a Result tab of a Services tool window, refer to [Result tabs](viewing-query-results.html#result_tabs).

Query result set: In-Editor Results:

1. [Toolbar.](#toolbar_controls)

2. The query result set in a [Table view](tables-view-data.html#data_view_modes_list).

For more information about In-Editor Results, refer to [In-Editor Results](viewing-query-results.html#in_editor_results).

User files data:

![Data editor tab in a delimiter-separated values file editor](https://resources.jetbrains.com.cn/help/img/idea/2026.2/data_editor_for_dsv_files_data.png)

1. Toolbar.

2. User file data.

For more information about working with the contents of user files, refer to  [Edit DSV files as tables](editing-csv-and-tsv-files.html) and [Data loaders](data-loaders.html).

The default [view mode](tables-view-data.html#data_view_modes) is Table. In this mode, you can [filter](tables-filter.html) and [sort](tables-sort.html) data, edit value of the [cells](cells.html) directly, and work with [rows](rows.html) of the data table.

Procedure: Open database object data

To open database object data in data editor, in the   Database   tool window , do one of the following:

* Double-click a database object.

* Select a database object and press `F4` (Windows), `⌘ ↓` (macOS), `F4` (IntelliJ IDEA Classic (macOS)), `F4` (macOS System Shortcuts), `F4` (XWin), `F4` (GNOME), `F4` (KDE), `F4` (Emacs), `F4` (Sublime Text), `F4` (Sublime Text (macOS)), `F4` (NetBeans), `F4` (Visual Studio), `⌘ ↓` (Visual Studio (macOS)), `F12` (Eclipse), `F3` (Eclipse (macOS)).

* Select a database object and click ![the Edit Data icon](https://resources.jetbrains.com.cn/help/img/idea/2026.2/database-plugin.icons.expui.table.svg) Edit Data on the toolbar.

* Right-click an object and select Edit Data.

![Data editor tab](https://resources.jetbrains.com.cn/help/img/idea/2026.2/data_editor_db_object_data.png)

Procedure: View query result set

To view a query result set in data editor, in a query console, do one of the following:

* Run an SQL query. The data editor opens in a Result tab of the Services tool window.

* Click ![the In-Editor Results icon](https://resources.jetbrains.com.cn/help/img/idea/2026.2/database-plugin.icons.expui.editorOutput.svg) In-Editor Results on the toolbar and run a query. The data editor opens in the query console in-editor results pane.

Services tool window:

For more information about a Result tab of a Services tool window, refer to [Result tabs](viewing-query-results.html#result_tabs).

In-Editor Results:

For more information about In-Editor Results, refer to [In-Editor Results](viewing-query-results.html#in_editor_results).

Procedure: View user files data as a table

* For tabular data user files of [supported
formats](data-loaders.html#supported_file_formats), do the following:

* In the Project tool window , click the tabular data file that you want to view as a table.

For such files, the table view is read-only.

![Contents of an Excel file are displayed in the data editor](https://resources.jetbrains.com.cn/help/img/idea/2026.2/tabular_data_file_data_in_data_editor_excel.png)

* For DSV user files, do the following:

1.

In the  Project tool window ,  click the DSV file that you want to view and edit as a table.

2.

Right-click inside a delimited text file and then click Edit as Table. Alternatively, you can click the Edit as Table icon in the editor.

3.

In the Configure CSV Format for <file_name> dialog that opens, specify format settings and click OK.

The dialog has three predefined formats (CSV, TSV, and Pipe-separated) and lets you create a custom format. For example, you may require comma-separated values with semicolons as row separators.

Once you confirm the format settings, the Data tab will present data in a table format correspondingly. If you want to use different format settings, repeat the previous procedure and open the data editor again.

[Video](https://resources.jetbrains.com.cn/help/img/idea/2026.2/open_dsv_file_as_table.mp4)

> **Tip:**
> If you want to edit only part of the data, select the necessary fragment inside the file.

Procedure: Close data editor

* To close data editor, click ![the Close icon](https://resources.jetbrains.com.cn/help/img/idea/2026.2/app.expui.general.closeSmall.svg) Close next to the corresponding tab title.

## Work with data

### View data

You can browse and edit data in three modes: Table,  Tree, Text, and Transpose. In the Table mode, you can also transpose the view. Use the value editor to view and edit the contents of a separate cell.

For full information on data view modes and other features, refer to [View data](tables-view-data.html).

![The transposed table viewing mode](https://resources.jetbrains.com.cn/help/img/idea/2026.2/db_viewing_modes_transposed_table.png)

### Compare data

Compare the data of two database objects. For comparison, you can define how many columns should differ to consider two columns equal. You can also select to ignore the extra column in either one of the objects.

For full information, refer to [Compare the data of database objects](compare-data.html).

![Compare table data tolerance equals to one](https://resources.jetbrains.com.cn/help/img/idea/2026.2/db_compare_table_data_tolerance_one.png)

### Sort data

You can sort data by clicking a column's header, or by entering a sorting query into the corresponding field. By default, each time you sort data, IntelliJ IDEA sends a new `ORDER BY` query to the database. You can also change the setting and sort data on the client side.

For more information about sorting data, refer to  the [Sort data](tables-sort.html) topic.

[Video](https://resources.jetbrains.com.cn/help/img/idea/2026.2/db_stacked_sorting.mp4)

### Filter data

Use one of the following ways to filter data:

* Specify filtering conditions.

* Run a search on the table.

* Enter a filtering query into the corresponding field.

For more information about filtering data, refer to  the [Filter data](tables-filter.html) topic.

![WHERE and ORDER BY fields for sorting](https://resources.jetbrains.com.cn/help/img/idea/2026.2/db_where_and_order_by_fields_for_sorting.png)

### Export data

IntelliJ IDEA uses data extractors to export data in various formats to a file or the clipboard. Each time you export or copy data, the copied data format is defined by the selected data extractor.

![Data extractor list on the data editor toolbar](https://resources.jetbrains.com.cn/help/img/idea/2026.2/db_toolbar_data_extractors_list.png)

You can use a built-in data extractor, configure a custom extractor based on CSV or DSV format, and create a custom data extractor using a provided API.

The last selected extractor becomes the default one for newly opened editor tabs. For MongoDB, the default extractor is always JSON.

For more information about data extractors, refer to the [corresponding page](data-extractors.html).

For more information about exporting data in IntelliJ IDEA, refer to  [Export data](export-data.html#methods-for-exporting-data).

### Rows

Manipulate the rows by adding, deleting, cloning them, and so on. You can also navigate between related rows, between subsets of rows, or go to a specified row.

For full information on these and other features, refer to [Rows](rows.html).

## Reference

Most of the available functions are accessed by using controls on the toolbar, context menu commands for the data cells, and associated keyboard shortcuts.

### Toolbar controls

| Icon | Action and shortcut | Description |
| --- | --- | --- |
|    ![First page](https://resources.jetbrains.com.cn/help/img/idea/2026.2/app-client.expui.actions.playFirst.svg)     ![Previous page](https://resources.jetbrains.com.cn/help/img/idea/2026.2/app-client.expui.actions.playBack.svg)    	![the Change page size button](https://resources.jetbrains.com.cn/help/img/idea/2026.2/db_page_size.png)   ![Next page](https://resources.jetbrains.com.cn/help/img/idea/2026.2/app-client.expui.actions.playForward.svg)     ![Last page](https://resources.jetbrains.com.cn/help/img/idea/2026.2/app-client.expui.actions.playLast.svg)    | First Page     Previous Page `Ctrl+Alt+Up` (Windows), `⌘ ⌥ ↑` (macOS), `⌘ ⌥ ↑` (IntelliJ IDEA Classic (macOS)), `⌘ ⌥ ↑` (macOS System Shortcuts), `Ctrl+Alt+Up` (XWin), `Ctrl+Alt+Up` (GNOME), `Ctrl+Alt+Up` (KDE), `Ctrl+Alt+Up` (Emacs), `Ctrl+Alt+Up` (Sublime Text), `⌘ ⌥ ↑` (Sublime Text (macOS)), `Ctrl+Alt+Up` (NetBeans), `Ctrl+Alt+Up` (Visual Studio), `⌘ ⌥ ↑` (Visual Studio (macOS)), `Ctrl+Alt+Up` (Eclipse), `⌘ ⌥ ↑` (Eclipse (macOS))     Change page size     Next Page `Ctrl+Alt+Down` (Windows), `⌘ ⌥ ↓` (macOS), `⌘ ⌥ ↓` (IntelliJ IDEA Classic (macOS)), `⌘ ⌥ ↓` (macOS System Shortcuts), `Ctrl+Alt+Down` (XWin), `Ctrl+Alt+Down` (GNOME), `Ctrl+Alt+Down` (KDE), `Ctrl+Alt+Down` (Emacs), `Ctrl+Alt+Down` (Sublime Text), `⌘ ⌥ ↓` (Sublime Text (macOS)), `Ctrl+Alt+Down` (NetBeans), `Ctrl+Alt+Down` (Visual Studio), `⌘ ⌥ ↓` (Visual Studio (macOS)), `Ctrl+Alt+Down` (Eclipse), `⌘ ⌥ ↓` (Eclipse (macOS))     Last Page    |     Available on the toolbar if the position is selected in the IDE settings (`Ctrl+Alt+S` (Windows), `⌘ Comma` (macOS), `⌘ Comma` (IntelliJ IDEA Classic (macOS)), `⌘ Comma` (macOS System Shortcuts), `Ctrl+Alt+S` (XWin), `Ctrl+Alt+S` (GNOME), `Ctrl+Alt+S` (KDE), `Ctrl+Alt+S` (Emacs), `Ctrl+Alt+S` (Sublime Text), `⌘ Comma` (Sublime Text (macOS)), `Ctrl+Alt+S` (NetBeans), `Ctrl+Alt+S` (Visual Studio), `⌘ Comma` (Visual Studio (macOS)), `Ctrl+Alt+S` (Eclipse), `⌘ Comma` (Eclipse (macOS))) under `Database \| Data editor and viewer \| Controls Customization \| Position of the grid pagination toolbar`.      Use navigation icons and corresponding commands for switching between pages that show the  table data   and change the page size.      A number of rows that you see on the  toolbar are referred to as a result set page. If this number is less than the number of rows in the table,  only a subset of all the rows is shown at a time. If all the rows are currently shown, navigation icons and the corresponding commands are inactive. You can see the limit between the navigation buttons. You can change it here by clicking and selecting the necessary limit or [in settings](#change_limit_in_settings).        * ![First page](https://resources.jetbrains.com.cn/help/img/idea/2026.2/app-client.expui.actions.playFirst.svg) First Page: jump to the first page of results.    * ![Previous page](https://resources.jetbrains.com.cn/help/img/idea/2026.2/app-client.expui.actions.playBack.svg) Previous Page: go to the previous page of results.    * ![Next page](https://resources.jetbrains.com.cn/help/img/idea/2026.2/app-client.expui.actions.playForward.svg) Next Page: go to the next page of results.    * ![Last page](https://resources.jetbrains.com.cn/help/img/idea/2026.2/app-client.expui.actions.playLast.svg) Last Page: jump to the last page of results.      To change the size of a result set page, click the Change page size button and select the size. Alternatively, open settings (`Ctrl+Alt+S` (Windows), `⌘ Comma` (macOS), `⌘ Comma` (IntelliJ IDEA Classic (macOS)), `⌘ Comma` (macOS System Shortcuts), `Ctrl+Alt+S` (XWin), `Ctrl+Alt+S` (GNOME), `Ctrl+Alt+S` (KDE), `Ctrl+Alt+S` (Emacs), `Ctrl+Alt+S` (Sublime Text), `⌘ Comma` (Sublime Text (macOS)), `Ctrl+Alt+S` (NetBeans), `Ctrl+Alt+S` (Visual Studio), `⌘ Comma` (Visual Studio (macOS)), `Ctrl+Alt+S` (Eclipse), `⌘ Comma` (Eclipse (macOS))) and navigate to  `Tools \| Database \| Data Editor and Viewer`. In the Limit page size to field, type a new size of a result set page. Alternatively, to disable the page size restriction, clear the Limit page size to checkbox.     |
|    ![the Reload Page icon](https://resources.jetbrains.com.cn/help/img/idea/2026.2/app-client.expui.general.refresh.svg)    |    Reload Page   `Ctrl+F5` (Windows), `⌘ R` (macOS), `⌃ F5` (IntelliJ IDEA Classic (macOS)), `⌘ R` (macOS System Shortcuts), `Ctrl+F5` (XWin), `Ctrl+F5` (GNOME), `Ctrl+5` (KDE), `Ctrl+F5` (Emacs), `Ctrl+F5` (Sublime Text), `⌘ R` (Sublime Text (macOS)), `Ctrl+F5` (NetBeans), `Ctrl+Alt+R` (Visual Studio), `⌘ ⌥ R` (Visual Studio (macOS)), `Ctrl+F5` (Eclipse), `Ctrl+F5` (Eclipse (macOS))  |    [Reload data](tables-view-data.html#updating_table_view) for the table view to synchronize the data that you see in the editor with the contents of the database. Also, use the Reload Page button when you want to apply a new [page                     size limit](rows.html#making_all_rows_visible_proc) setting after its change.    |
| ![the Update Interval icon](https://resources.jetbrains.com.cn/help/img/idea/2026.2/app-client.expui.general.history.svg) | Update Interval | Select, pause, or disable update interval for the current table. You can also set a custom one. |
|     ![the Cancel Running Statements icon](https://resources.jetbrains.com.cn/help/img/idea/2026.2/app-client.expui.run.stop.svg)          |  Cancel Running Statements    `Ctrl+F2` (Windows), `⌘ F2` (macOS), `⌘ F2` (IntelliJ IDEA Classic (macOS)), `⌃ ⇧ .` (macOS System Shortcuts), `Ctrl+F2` (XWin), `Ctrl+F2` (GNOME), `Ctrl+2` (KDE), `Ctrl+F2` (Emacs), `Ctrl+F2` (Sublime Text), `Ctrl+F2` (Sublime Text (macOS)), `Shift+F5` (NetBeans), `Shift+F5` (Visual Studio), `⇧ F5` (Visual Studio (macOS)), `Ctrl+F2` (Eclipse), `⌘ F2` (Eclipse (macOS))  |  Terminate execution of the current statement or statements.   |
|    ![the Add Row icon](https://resources.jetbrains.com.cn/help/img/idea/2026.2/app-client.expui.general.add.svg)    |    Add Row   `Alt+Insert` (Windows), `⌘ N` (macOS), `⌃ N` (IntelliJ IDEA Classic (macOS)), `⌘ N` (macOS System Shortcuts), `Alt+Insert` (XWin), `Alt+Insert` (GNOME), `Alt+Insert` (KDE), `Alt+Insert` (Emacs), `Ctrl+N` (Sublime Text), `⌘ N` (Sublime Text (macOS)), `Alt+Insert` (NetBeans), `Ctrl+N` (Visual Studio), `⌘ N` (Visual Studio (macOS)), `Alt+Insert` (Eclipse), `⌘ N` (Eclipse (macOS))  |    Add a row to the table.      To save a new row, click ![the Submit button](https://resources.jetbrains.com.cn/help/img/idea/2026.2/database-plugin.icons.expui.submitDB.svg) Submit on the toolbar.        For more information about working with rows, refer to [Tables](working-with-the-data-editor.html).       |
|    ![the Delete Row icon](https://resources.jetbrains.com.cn/help/img/idea/2026.2/app-client.expui.general.remove.svg)    |    Delete Row   `Ctrl+Y` (Windows), `⌘ ⌫` (macOS), `⌘ Y` (IntelliJ IDEA Classic (macOS)), `⌘ ⌫` (macOS System Shortcuts), `Ctrl+Y` (XWin), `Ctrl+Y` (GNOME), `Ctrl+Y` (KDE), `Ctrl+Y` (Emacs), `Ctrl+Shift+K` (Sublime Text), `⌃ ⇧ K` (Sublime Text (macOS)), `Ctrl+E` (NetBeans), `Ctrl+L` (Visual Studio), `⌘ ⇧ L` (Visual Studio (macOS)), `Ctrl+D` (Eclipse), `⌘ D` (Eclipse (macOS))  | Delete the selected row or rows.       To select multiple rows, click numbers in the gutter. Also, you can press `Ctrl` (Windows), `Ctrl` (macOS), `Ctrl` (IntelliJ IDEA Classic (macOS)), `Ctrl` (macOS System Shortcuts), `Ctrl` (XWin), `Ctrl` (GNOME), `Ctrl` (KDE), `Ctrl` (Emacs), `Ctrl` (Sublime Text), `Ctrl` (Sublime Text (macOS)), `Ctrl` (NetBeans), `Ctrl` (Visual Studio), `Ctrl` (Visual Studio (macOS)), `Ctrl` (Eclipse), `Ctrl` (Eclipse (macOS)) and click the necessary rows.       |
| ![the Revert Selected button](https://resources.jetbrains.com.cn/help/img/idea/2026.2/app-client.expui.general.reset.svg) | Revert Selected     `Ctrl+Alt+Z` (Windows), `⌘ ⌥ Z` (macOS), `⌘ ⌥ Z` (IntelliJ IDEA Classic (macOS)), `⌘ ⌥ Z` (macOS System Shortcuts), `Ctrl+Alt+Z` (XWin), `Ctrl+Alt+Z` (GNOME), `Ctrl+Alt+Z` (KDE), `Ctrl+Alt+Z` (Emacs), `Ctrl+Alt+Z` (Sublime Text), `⌘ ⌥ Z` (Sublime Text (macOS)), `Ctrl+Alt+Z` (NetBeans), `Ctrl+Alt+Z` (Visual Studio), `⌘ ⌥ Z` (Visual Studio (macOS)), `Ctrl+Alt+Z` (Eclipse), `⌃ ⌥ ⇧ Z` (Eclipse (macOS))   |    Revert changes that you made to a cell value. You can select a scope of different cells and revert values in this scope.     For more information about reverting changes, refer to [Submit changes to a database](submitting-and-reverting-changes.html).    |
| ![the Preview Pending Changes icon](https://resources.jetbrains.com.cn/help/img/idea/2026.2/database-plugin.icons.expui.previewChanges.svg) | Preview Pending Changes   | [Preview DML](tables-view-data.html#preview-dml) of changes that you made to the table.     |
|    ![the Submit button](https://resources.jetbrains.com.cn/help/img/idea/2026.2/database-plugin.icons.expui.submitDB.svg)    |     Submit     `Ctrl+Enter` (Windows), `⌘ ⏎` (macOS), `⌘ ⏎` (IntelliJ IDEA Classic (macOS)), `⌘ ⏎` (macOS System Shortcuts), `Ctrl+Enter` (XWin), `Ctrl+Enter` (GNOME), `Ctrl+Enter` (KDE), `Ctrl+Enter` (Emacs), `Ctrl+Enter` (Sublime Text), `⌘ ⏎` (Sublime Text (macOS)), `Ctrl+Enter` (NetBeans), `Ctrl+Enter` (Visual Studio), `⌘ ⏎` (Visual Studio (macOS)), `Ctrl+Enter` (Eclipse), `⌘ ⏎` (Eclipse (macOS))      |  Submit local changes to the database server. For more information about submitting and reverting changes, refer to [Submit changes to a database](submitting-and-reverting-changes.html).  |
| ![Transaction mode](https://resources.jetbrains.com.cn/help/img/idea/2026.2/buttonTransactionControlDB.png)     | Transaction Mode     and     Transaction Isolation    |    Select the [isolation level](https://en.wikipedia.org/wiki/Isolation_(database_systems)) for database transactions and the way the transactions are committed.       * Auto: the current transaction is committed automatically when you submit your local changes to the database server.    * Manual: the changes submitted to the database server are accumulated in a transaction that can either be committed or rolled back explicitly by means of ![the Submit and Commit icon](https://resources.jetbrains.com.cn/help/img/idea/2026.2/database-plugin.icons.expui.commit.svg) Submit and Commit or ![the Roll Back button](https://resources.jetbrains.com.cn/help/img/idea/2026.2/database-plugin.icons.expui.rollback.svg) Roll Back buttons on the toolbar.      For more information about database transaction modes and isolation, refer to [Submit changes to a database](submitting-and-reverting-changes.html).     |
|    ![the Submit and Commit icon](https://resources.jetbrains.com.cn/help/img/idea/2026.2/database-plugin.icons.expui.commit.svg)     |    Submit and Commit`Ctrl+Alt+Shift+Enter` (Windows), `⌘ ⌥ ⇧ ⏎` (macOS), `⌘ ⌥ ⇧ ⏎` (IntelliJ IDEA Classic (macOS)), `⌘ ⌥ ⇧ ⏎` (macOS System Shortcuts), `Ctrl+Alt+Shift+Enter` (XWin), `Ctrl+Alt+Shift+Enter` (GNOME), `Ctrl+Alt+Shift+Enter` (KDE), `Ctrl+Alt+Shift+Enter` (Emacs), `Ctrl+Alt+Shift+Enter` (Sublime Text), `⌘ ⌥ ⇧ ⏎` (Sublime Text (macOS)), `Ctrl+Alt+Shift+Enter` (NetBeans), `Ctrl+Alt+Shift+Enter` (Visual Studio), `⌘ ⌥ ⇧ ⏎` (Visual Studio (macOS)), `Ctrl+Alt+Shift+Enter` (Eclipse), `⌘ ⌥ ⇧ ⏎` (Eclipse (macOS))     |     (For the Manual transaction mode.) Submit and commit  the current transaction. This button is available only for the manual transaction mode. See also, [transaction mode and                     isolation](submitting-and-reverting-changes.html).     |
|   ![the Roll Back icon](https://resources.jetbrains.com.cn/help/img/idea/2026.2/database-plugin.icons.expui.rollback.svg)   |      Roll Back      |  (For the Manual transaction mode.) Roll back changes. This button is available only for the manual transaction mode. See also, [transaction modes and isolation](submitting-and-reverting-changes.html).  |
|  ![Go to DDL](https://resources.jetbrains.com.cn/help/img/idea/2026.2/db_go_to_ddl.png)  | Go to DDL   |    Open DDL of the object in the editor.     |
| ![the Find on Current Page button](https://resources.jetbrains.com.cn/help/img/idea/2026.2/app-client.expui.general.search.svg)   | Find on Current Page     `Ctrl+F` (Windows), `⌘ F` (macOS), `⌘ F` (IntelliJ IDEA Classic (macOS)), `⌘ F` (macOS System Shortcuts), `Ctrl+F` (XWin), `Ctrl+F` (GNOME), `Ctrl+F` (KDE), `Ctrl+Alt+S` (Emacs), `Ctrl+F` (Sublime Text), `⌘ F` (Sublime Text (macOS)), `Ctrl+F` (NetBeans), `Ctrl+F` (Visual Studio), `⌘ F` (Visual Studio (macOS)), `Ctrl+F` (Eclipse), `Ctrl+F` (Eclipse (macOS))   | Opens a search field for the current page of results.   |
|  ![the Enable Local Filter icon](https://resources.jetbrains.com.cn/help/img/idea/2026.2/intellij.grid.core.impl.icons.expui.columnFilter.svg)  |  Enable Local Filter  |    Enables a local filter for every column of the grid.       For more information about local filter, refer to  the [Filter data](tables-filter.html#use_the_local_filter) topic.     |
|   ![the Show Record View icon](https://resources.jetbrains.com.cn/help/img/idea/2026.2/intellij.grid.core.impl.icons.expui.singleRecordView.svg)   |  Record View  |     View and edit values of a certain record in a side panel.       For more information about the action, refer to  the [View data](tables-view-data.html#single_record_view) topic.      |
|  ![the Show Geo Viewer icon](https://resources.jetbrains.com.cn/help/img/idea/2026.2/app-client.expui.nodes.ppWeb.svg)  |  Show Geo Viewer  |    Enables a graphic viewer to explore geospatial data in your database.       For more information about the Geo viewer, refer to  the [Using Geo viewer for geographical data in PostgreSQL](tables-view-data.html).     |
|  ![the Show Chart icon](https://resources.jetbrains.com.cn/help/img/idea/2026.2/intellij.charts.icons.chart.chart.svg)  |  Show Chart  |    Opens data visualization.       For more information about about charts, refer to  [Visualize data](tables-view-data.html#visualize_data).     |
|   	![Data Extractor](https://resources.jetbrains.com.cn/help/img/idea/2026.2/DataExtractorButton.png)  | Data Extractors   |    Select an output format for your data. For the list of available formats and full information about data extractors, refer to the [Data extractors](data-extractors.html) topic.     Also, you can configure the following options:       * Skip Computed Columns: do not include virtual columns that are not physically stored in the table (for example, the identity column).    * Skip Generated Columns: for `INSERT` and `UPDATE` statements, do not include auto-increment fields when copying or saving data.    * Configure CSV Formats: open the [CSV Formats](data-extractors.html#csv_formats_dialog) dialog where you can manage your delimiter-separated values formats (for example, CSV, TSV).    * Go To Scripts Directory: open a directory with scripts that convert table data into different output formats.      For more information about data extractors, refer to the [Data extractors](data-extractors.html) topic.    |
|    ![the Export Data icon](https://resources.jetbrains.com.cn/help/img/idea/2026.2/app-client.expui.general.download.svg)    |    Export Data   |  Export the table data to the clipboard or save to a file.  |
|  ![the Copy to Database icon](https://resources.jetbrains.com.cn/help/img/idea/2026.2/app-client.expui.general.upload.svg)   | Copy to Database   |     Copy the data to another table, schema or database. Select the target schema (a new table will be created) or table (the data will be added to the selected table). In the dialog that opens, specify the data mapping info and the settings for the target table.     |
|    ![the Compare Data icon](https://resources.jetbrains.com.cn/help/img/idea/2026.2/app-client.expui.vcs.diff.svg)    |    Compare Data   |    Compare the current table with a table from the list.     For more information about comparing tables, refer to [Compare table data](compare-data.html#compare-table-data).    |
| ![the View as icon](https://resources.jetbrains.com.cn/help/img/idea/2026.2/app-client.expui.general.show.svg) | View as | Select the mode for browsing and editing table data.       * Transpose: viewing mode in which rows and columns are [interchanged](tables-view-data.html#transposing_table). You can combine this checkbox with other viewing modes. To make this mode a default for tables and views, open settings by pressing `Ctrl+Alt+S` (Windows), `⌘ Comma` (macOS), `⌘ Comma` (IntelliJ IDEA Classic (macOS)), `⌘ Comma` (macOS System Shortcuts), `Ctrl+Alt+S` (XWin), `Ctrl+Alt+S` (GNOME), `Ctrl+Alt+S` (KDE), `Ctrl+Alt+S` (Emacs), `Ctrl+Alt+S` (Sublime Text), `⌘ Comma` (Sublime Text (macOS)), `Ctrl+Alt+S` (NetBeans), `Ctrl+Alt+S` (Visual Studio), `⌘ Comma` (Visual Studio (macOS)), `Ctrl+Alt+S` (Eclipse), `⌘ Comma` (Eclipse (macOS)) and navigate to `Tools \| Database \| Data Editor and Viewer`. From the Automatically transpose tables list, select Always. When this option is enabled, query results are not transposed.    * Table: the default viewing mode of table data. Data in a table is stored in a cell that is an intersection of a vertical column and horizontal row.    * Tree: viewing mode in which data is displayed in the key-value table with the possibility to expand the key cell if it contains children nodes. Data from the expanded children node is distributed between key and value columns. You might consider using this mode to work with JSON and array data.    * Text: viewing mode in which data is displayed as a text. This mode uses data extractors to represent the data. For example, if the CSV data extractor is selected in the Data extractors list on the toolbar, the database object data is displayed in the CSV format. For more information about data extractors, refer to the [Data extractors](data-extractors.html) topic.     For more information about viewing data, refer to [View data](tables-view-data.html).    |
|    ![the Show Options Menu icon](https://resources.jetbrains.com.cn/help/img/idea/2026.2/app-client.expui.general.settings.svg)    | Show Options Menu   |    The Show Options Menu list includes the following options:       * Show Value Editor: open a separate editor where you can edit data that is stored in the cell. For more information about the editor, refer to [Value editor](tables-view-data.html#value-editor).    * Show Aggregate View: open the aggregate view where you can select values of multiple cells and get a single summary value. For more information about the view, refer to [Aggregate view](tables-view-data.html#aggregate-view).    * Sort via ORDER BY: sort data on the database side by sending a new `ORDER BY` query to the database. The client-side sorting does not run any new queries and sorts only the current page. > **Note:** > Server side sorting is only available for the [database objects data](#open_database_object_data), not for the [query results set](#view_query_result_set). > **Tip:** > Do not turn this option on if you want to keep interactions with the database to a minimum. For example, when the table is large or the connection to your database is slow. If you want to use sorting on the client side, clear the Sort via ORDER BY checkbox. You can define which sorting method to use as the default for tables. To do that, open settings by pressing `Ctrl+Alt+S` (Windows), `⌘ Comma` (macOS), `⌘ Comma` (IntelliJ IDEA Classic (macOS)), `⌘ Comma` (macOS System Shortcuts), `Ctrl+Alt+S` (XWin), `Ctrl+Alt+S` (GNOME), `Ctrl+Alt+S` (KDE), `Ctrl+Alt+S` (Emacs), `Ctrl+Alt+S` (Sublime Text), `⌘ Comma` (Sublime Text (macOS)), `Ctrl+Alt+S` (NetBeans), `Ctrl+Alt+S` (Visual Studio), `⌘ Comma` (Visual Studio (macOS)), `Ctrl+Alt+S` (Eclipse), `⌘ Comma` (Eclipse (macOS)) and navigate to `Tools \| Database \| Data Editor and Viewer`. . In the Data Sorting section, select or clear the Sort via ORDER BY checkbox. For more information about sorting data, refer to [Sort data](tables-sort.html).    * Show Filter: show or hide the filter box.    * Paste Format: select how you want to treat the text from the clipboard on paste.    * Reset View: restore the initial table view if you customized the table view before (for example, hidden columns or sorted data).    * View Query: [view the query](tables-view-data.html#view-the-query-that-generated-the-result-set) that generated the table.    * Copy Query to Console: copy the query that generated the table to query console.    * Copy Query to Clipboard: copy the query that generated the table to the clipboard.    * Open Data View Settings...: open the Data Editor and Viewer section in settings, where you can define how table data are shown and modified in your query consoles and data editors. For more information about the Data Editor and Viewer settings section, refer to [Data editor and viewer](settings-tools-database-data-views.html).    |

### Context menu

You can find all basic actions for working with cells under the context menu. To call the context menu, right-click the cell that you want to modify. The following table lists all the actions.

![Context menu of a cell in data editor](https://resources.jetbrains.com.cn/help/img/idea/2026.2/db_cell_context_menu.png)

| Action | Shortcut | Description |
| --- | --- | --- |
|    Edit    |  `Enter` (Windows), `⏎` (macOS), `⏎` (IntelliJ IDEA Classic (macOS)), `⏎` (macOS System Shortcuts), `Enter` (XWin), `Enter` (GNOME), `Enter` (KDE), `Enter` (Emacs), `Enter` (Sublime Text), `⏎` (Sublime Text (macOS)), `Enter` (NetBeans), `Enter` (Visual Studio), `⏎` (Visual Studio (macOS)), `Enter` (Eclipse), `⏎` (Eclipse (macOS))   |    Edit a value in the selected cell or cells. Alternatively, you can double-click the cell and start typing a value. The Edit command is unavailable for read-only values.       * To open the auto-completion list, press `Ctrl+Space` (Windows), `⌃ Space` (macOS), `⌃ Space` (IntelliJ IDEA Classic (macOS)), `⌃ Space` (macOS System Shortcuts), `Ctrl+Space` (XWin), `Ctrl+Space` (GNOME), `Ctrl+Space` (KDE), `Alt+/` (Emacs), `Ctrl+Space` (Sublime Text), `⌃ Space` (Sublime Text (macOS)), `Ctrl+Space` (NetBeans), `Ctrl+Space` (Visual Studio), `⌃ Space` (Visual Studio (macOS)), `Ctrl+Space` (Eclipse), `⌃ Space` (Eclipse (macOS)).    * To confirm your changes, press `Enter` (Windows), `⏎` (macOS), `⏎` (IntelliJ IDEA Classic (macOS)), `⏎` (macOS System Shortcuts), `Enter` (XWin), `Enter` (GNOME), `Enter` (KDE), `Enter` (Emacs), `Enter` (Sublime Text), `⏎` (Sublime Text (macOS)), `Enter` (NetBeans), `Enter` (Visual Studio), `⏎` (Visual Studio (macOS)), `Enter` (Eclipse), `⏎` (Eclipse (macOS)).    * To cancel editing, press `Escape` (Windows), `⎋` (macOS), `⎋` (IntelliJ IDEA Classic (macOS)), `⎋` (macOS System Shortcuts), `Escape` (XWin), `Escape` (GNOME), `Escape` (KDE), `Escape, Escape` (Emacs), `Escape` (Sublime Text), `⎋` (Sublime Text (macOS)), `Escape` (NetBeans), `Escape` (Visual Studio), `⎋` (Visual Studio (macOS)), `Escape` (Eclipse), `⎋` (Eclipse (macOS)).      For more information about editing cells, refer to [Cells](cells.html).     |
|   ![the Show Record View icon](https://resources.jetbrains.com.cn/help/img/idea/2026.2/intellij.grid.core.impl.icons.expui.singleRecordView.svg)  Show Record View  |  |     View and edit values of a certain record in a side panel.       For more information about the action, refer to  the [View data](tables-view-data.html#single_record_view) topic.      |
|  Open in Value Editor | `Shift+Enter` (Windows), `⇧ ⏎` (macOS), `⇧ ⏎` (IntelliJ IDEA Classic (macOS)), `⇧ ⏎` (macOS System Shortcuts), `Shift+Enter` (XWin), `Shift+Enter` (GNOME), `Shift+Enter` (KDE), `Shift+Enter` (Emacs), `Shift+Enter` (Sublime Text), `⇧ ⏎` (Sublime Text (macOS)), `Shift+Enter` (NetBeans), `Shift+Enter` (Visual Studio), `⇧ ⏎` (Visual Studio (macOS)), `Shift+Enter` (Eclipse), `⇧ ⏎` (Eclipse (macOS)) |    Open in a separate value editor where you can edit data that is stored in the cell.      For more information about the editor, refer to [Value editor](tables-view-data.html#value-editor).    |
|  Show Aggregate View |  |    Open the aggregate view where you can select values of multiple cells and get a single summary value.     For more information about the view, refer to [Aggregate view]().    |
| ![the Revert Selected button](https://resources.jetbrains.com.cn/help/img/idea/2026.2/app-client.expui.general.reset.svg) Revert Selected | `Ctrl+Alt+Z` (Windows), `⌘ ⌥ Z` (macOS), `⌘ ⌥ Z` (IntelliJ IDEA Classic (macOS)), `⌘ ⌥ Z` (macOS System Shortcuts), `Ctrl+Alt+Z` (XWin), `Ctrl+Alt+Z` (GNOME), `Ctrl+Alt+Z` (KDE), `Ctrl+Alt+Z` (Emacs), `Ctrl+Alt+Z` (Sublime Text), `⌘ ⌥ Z` (Sublime Text (macOS)), `Ctrl+Alt+Z` (NetBeans), `Ctrl+Alt+Z` (Visual Studio), `⌘ ⌥ Z` (Visual Studio (macOS)), `Ctrl+Alt+Z` (Eclipse), `⌃ ⌥ ⇧ Z` (Eclipse (macOS)) |    Revert changes that you made to a cell value. You can select a scope of different cells and revert values in this scope.     For more information about reverting changes, refer to [Submit changes to a database](submitting-and-reverting-changes.html).    |
| Set Highlighting Language |  | Select a language that the IDE should use to highlight data in a cell. |
| Change Display Type |  | Select how the IDE should display binary data in the column. 16-byte data is displayed as UUID by default. |
| Set DEFAULT |  `Ctrl+Alt+D` (Windows), `⌘ ⌥ D` (macOS), `⌘ ⌥ D` (IntelliJ IDEA Classic (macOS)), `⌃ ⌥ ⇧ D` (macOS System Shortcuts), `Ctrl+Alt+D` (XWin), `Ctrl+Alt+D` (GNOME), `Ctrl+Alt+D` (KDE), `Ctrl+Alt+D` (Emacs), `Ctrl+Alt+D` (Sublime Text), `⌘ ⌥ D` (Sublime Text (macOS)), `Ctrl+Alt+D` (NetBeans), `Ctrl+Alt+D` (Visual Studio), `⌘ ⌥ D` (Visual Studio (macOS)), `Ctrl+Alt+D` (Eclipse), `⌘ ⌥ D` (Eclipse (macOS))   | Set the current cell value to the default value or the value that you specified for the column.     For more information about viewing or set a default value, refer to [Manage default and NULL values                             for a cell](cells.html#manage-default-values-for-a-cell).    |
| NULL | `Ctrl+Alt+N` (Windows), `⌘ ⌥ N` (macOS), `⌘ ⌥ N` (IntelliJ IDEA Classic (macOS)), `⌘ ⌥ N` (macOS System Shortcuts), `Ctrl+Alt+N` (XWin), `Ctrl+Alt+N` (GNOME), `Ctrl+Alt+N` (KDE), `Ctrl+Alt+N` (Emacs), `Ctrl+Alt+N` (Sublime Text), `⌘ ⌥ N` (Sublime Text (macOS)), `Ctrl+Alt+N` (NetBeans), `Ctrl+Alt+N` (Visual Studio), `⌘ ⌥ N` (Visual Studio (macOS)), `Ctrl+Alt+N` (Eclipse), `⌘ ⌥ N` (Eclipse (macOS)) | Set the current cell value to NULL.     For more information about allowing a NULL value, refer to [Manage default and NULL values for a cell](cells.html#manage-default-values-for-a-cell).    |
| Generate UUID |  | Generates the UUID for the selected cell.    |
| Load File… |  | Load a file into the field.    |
| Save LOB… |  | For the cells that contain a binary large object ([LOB](http://en.wikipedia.org/wiki/Binary_large_object)). Save content of a cell into a file. |
| ![the Copy icon](https://resources.jetbrains.com.cn/help/img/idea/2026.2/app-client.expui.general.copy.svg) Copy | `Ctrl+C` (Windows), `⌘ C` (macOS), `⌘ C` (IntelliJ IDEA Classic (macOS)), `⌘ C` (macOS System Shortcuts), `Ctrl+C` (XWin), `Ctrl+C` (GNOME), `Ctrl+C` (KDE), `Ctrl+Insert` (Emacs), `Ctrl+C` (Sublime Text), `⌘ C` (Sublime Text (macOS)), `Ctrl+C` (NetBeans), `Ctrl+C` (Visual Studio), `⌘ C` (Visual Studio (macOS)), `Ctrl+C` (Eclipse), `⌘ C` (Eclipse (macOS)) | Copy selection to the clipboard. |
| Change Data Extractor |  |  Change the [data extractor](data-extractors.html) currently selected from the Data Extractors list on the toolbar.  |
| ![the Copy Aggregation Result (SUM) icon](https://resources.jetbrains.com.cn/help/img/idea/2026.2/app-client.expui.general.copy.svg) Copy Aggregation Result (SUM) |    | Copy a summary value for a range of cells. By default, IntelliJ IDEA copies the `SUM` aggregation result. To change the default, right-click the status bar and ensure that the Aggregator option is selected. Click the aggregator widget on the status bar and select the aggregator to use as default.     |
| ![the Paste icon](https://resources.jetbrains.com.cn/help/img/idea/2026.2/app-client.expui.general.paste.svg) Paste | `Ctrl+V` (Windows), `⌘ V` (macOS), `⌘ V` (IntelliJ IDEA Classic (macOS)), `⌘ V` (macOS System Shortcuts), `Ctrl+V` (XWin), `Ctrl+V` (GNOME), `Ctrl+V` (KDE), `Shift+Insert` (Emacs), `Ctrl+Shift+V` (Sublime Text), `⌘ ⇧ V` (Sublime Text (macOS)), `Ctrl+V` (NetBeans), `Ctrl+V` (Visual Studio), `⌘ V` (Visual Studio (macOS)), `Ctrl+V` (Eclipse), `⌘ V` (Eclipse (macOS)) | Paste the contents of clipboard into the table. |
| ![](https://resources.jetbrains.com.cn/help/img/idea/2026.2/app.expui.general.add.svg) Add Row |    | Add a row to the end of a table. |
| ![](https://resources.jetbrains.com.cn/help/img/idea/2026.2/app.expui.general.remove.svg) Delete Row | `Alt+Delete` (Windows), `Alt+Delete` (macOS), `Alt+Delete` (IntelliJ IDEA Classic (macOS)), `Alt+Delete` (macOS System Shortcuts), `Alt+Delete` (XWin), `Alt+Delete` (GNOME), `Alt+Delete` (KDE), `Alt+Delete` (Emacs), `Alt+Delete` (Sublime Text), `Alt+Delete` (Sublime Text (macOS)), `Alt+Delete` (NetBeans), `Alt+Delete` (Visual Studio), `Alt+Delete` (Visual Studio (macOS)), `Alt+Delete` (Eclipse), `Alt+Delete` (Eclipse (macOS))  | Delete selected rows. |
| ![](https://resources.jetbrains.com.cn/help/img/idea/2026.2/app.expui.general.copy.svg) Clone Row |    | Create a duplicate of the selected row and adds the duplicate to the end of a table. |
| Go To | Navigation Bar | `Alt+Home` (Windows), `⌘ ↑` (macOS), `⌥ Home` (IntelliJ IDEA Classic (macOS)), `⌘ ⌃ ↑` (macOS System Shortcuts), `Alt+Home` (XWin), `Alt+Home` (GNOME), `Alt+Home` (KDE), `Alt+Home` (Emacs), `Alt+Home` (Sublime Text), `⌥ Home` (Sublime Text (macOS)), `Alt+Home` (NetBeans), `Ctrl+F2` (Visual Studio), `⌘ F2` (Visual Studio (macOS)), `Alt+Home` (Eclipse), `⌘ ⌥ B` (Eclipse (macOS)) | Jump to a navigation bar. |
| Database | `Alt+Shift+B` (Windows), `⌥ ⇧ B` (macOS), `⌥ ⇧ B` (IntelliJ IDEA Classic (macOS)), `⌥ ⇧ B` (macOS System Shortcuts), `Alt+Shift+B` (XWin), `Alt+Shift+B` (GNOME), `Alt+Shift+B` (KDE), `Alt+Shift+B` (Emacs), `Alt+Shift+B` (Sublime Text), `⌥ ⇧ B` (Sublime Text (macOS)), `Alt+Shift+B` (NetBeans), `Alt+Shift+B` (Visual Studio), `⌥ ⇧ B` (Visual Studio (macOS)), `Alt+Shift+B` (Eclipse), `⌥ ⇧ B` (Eclipse (macOS)) | Open the selected object in the   Database   tool window . |
| Related Symbol… | `Ctrl+Alt+Home` (Windows), `⌘ ⌃ ↑` (macOS), `⌘ ⌥ Home` (IntelliJ IDEA Classic (macOS)), `⌘ ⌃ ↓` (macOS System Shortcuts), `Ctrl+Alt+Home` (XWin), `Ctrl+Alt+Home` (GNOME), `Ctrl+Alt+Home` (KDE), `Ctrl+Alt+Home` (Emacs), `Ctrl+Alt+Home` (Sublime Text), `Ctrl+Alt+Home` (Sublime Text (macOS)), `Ctrl+Alt+Home` (NetBeans), `Ctrl+Alt+F7` (Visual Studio), `⌘ ⇧ F7` (Visual Studio (macOS)), `Ctrl+Alt+Home` (Eclipse), `⌘ ⌃ ↑` (Eclipse (macOS)) | Navigate to one of the related objects. |
| DDL | `Ctrl+Alt+Home` (Windows), `⌘ ⌃ ↑` (macOS), `⌘ ⌥ Home` (IntelliJ IDEA Classic (macOS)), `⌘ ⌃ ↓` (macOS System Shortcuts), `Ctrl+Alt+Home` (XWin), `Ctrl+Alt+Home` (GNOME), `Ctrl+Alt+Home` (KDE), `Ctrl+Alt+Home` (Emacs), `Ctrl+Alt+Home` (Sublime Text), `Ctrl+Alt+Home` (Sublime Text (macOS)), `Ctrl+Alt+Home` (NetBeans), `Ctrl+Alt+F7` (Visual Studio), `⌘ ⇧ F7` (Visual Studio (macOS)), `Ctrl+Alt+Home` (Eclipse), `⌘ ⌃ ↑` (Eclipse (macOS)) | Open an object definition (DDL). |
| Row… | `Ctrl+G` (Windows), `⌘ L` (macOS), `⌘ G` (IntelliJ IDEA Classic (macOS)), `⌘ L` (macOS System Shortcuts), `Ctrl+G` (XWin), `Ctrl+G` (GNOME), `Ctrl+G` (KDE), `Alt+G` (Emacs), `Ctrl+G` (Sublime Text), `⌃ G` (Sublime Text (macOS)), `Ctrl+G` (NetBeans), `Ctrl+G` (Visual Studio), `⌘ G` (Visual Studio (macOS)), `Ctrl+L` (Eclipse), `⌘ L` (Eclipse (macOS)) | Jump to a specified row.     In the Go to Row dialog, specify the column and row number (use the `column:row` pattern).   |
| ![the Related Rows icon](https://resources.jetbrains.com.cn/help/img/idea/2026.2/database-plugin.icons.expui.goToTable.svg) Related Rows | `F4` (Windows), `⌘ ↓` (macOS), `F4` (IntelliJ IDEA Classic (macOS)), `F4` (macOS System Shortcuts), `F4` (XWin), `F4` (GNOME), `F4` (KDE), `F4` (Emacs), `F4` (Sublime Text), `F4` (Sublime Text (macOS)), `F4` (NetBeans), `F4` (Visual Studio), `⌘ ↓` (Visual Studio (macOS)), `F12` (Eclipse), `F3` (Eclipse (macOS)) |    Navigates to the related records:       * Records that the current record references.    * Records that reference the current record.     If more than one record is referenced or referencing the current one, select the target record in the popup that appears.     The action is not available if there are no related records.       For more information about related data, refer to  [Navigate between related rows](rows.html#navigate-between-related-rows).        For more information about action behavior options, refer to  [Advanced Settings](advanced-settings.html#related_rows_action_behavior).     |
| ![the Open URL icon](https://resources.jetbrains.com.cn/help/img/idea/2026.2/app.expui.toolwindows.web.svg) Open URL | `F4` (Windows), `⌘ ↓` (macOS), `F4` (IntelliJ IDEA Classic (macOS)), `F4` (macOS System Shortcuts), `F4` (XWin), `F4` (GNOME), `F4` (KDE), `F4` (Emacs), `F4` (Sublime Text), `F4` (Sublime Text (macOS)), `F4` (NetBeans), `F4` (Visual Studio), `⌘ ↓` (Visual Studio (macOS)), `F12` (Eclipse), `F3` (Eclipse (macOS)) |    Opens URL in OS default browser.      Requires the links opening URL Click Settings enabled in  the Tools \| Database \| Data Editor and Viewer settings page `Ctrl+Alt+S` (Windows), `⌘ Comma` (macOS), `⌘ Comma` (IntelliJ IDEA Classic (macOS)), `⌘ Comma` (macOS System Shortcuts), `Ctrl+Alt+S` (XWin), `Ctrl+Alt+S` (GNOME), `Ctrl+Alt+S` (KDE), `Ctrl+Alt+S` (Emacs), `Ctrl+Alt+S` (Sublime Text), `⌘ Comma` (Sublime Text (macOS)), `Ctrl+Alt+S` (NetBeans), `Ctrl+Alt+S` (Visual Studio), `⌘ Comma` (Visual Studio (macOS)), `Ctrl+Alt+S` (Eclipse), `⌘ Comma` (Eclipse (macOS)) .     |
| ![the Open File icon](https://resources.jetbrains.com.cn/help/img/idea/2026.2/app.expui.inline.browse.svg) Open File | `F4` (Windows), `⌘ ↓` (macOS), `F4` (IntelliJ IDEA Classic (macOS)), `F4` (macOS System Shortcuts), `F4` (XWin), `F4` (GNOME), `F4` (KDE), `F4` (Emacs), `F4` (Sublime Text), `F4` (Sublime Text (macOS)), `F4` (NetBeans), `F4` (Visual Studio), `⌘ ↓` (Visual Studio (macOS)), `F12` (Eclipse), `F3` (Eclipse (macOS)) |    Open file URI in OS default file browser. For example, `file:///Users/Username/image.png`.      Requires the links opening URL Click Settings enabled in  the Tools \| Database \| Data Editor and Viewer settings page `Ctrl+Alt+S` (Windows), `⌘ Comma` (macOS), `⌘ Comma` (IntelliJ IDEA Classic (macOS)), `⌘ Comma` (macOS System Shortcuts), `Ctrl+Alt+S` (XWin), `Ctrl+Alt+S` (GNOME), `Ctrl+Alt+S` (KDE), `Ctrl+Alt+S` (Emacs), `Ctrl+Alt+S` (Sublime Text), `⌘ Comma` (Sublime Text (macOS)), `Ctrl+Alt+S` (NetBeans), `Ctrl+Alt+S` (Visual Studio), `⌘ Comma` (Visual Studio (macOS)), `Ctrl+Alt+S` (Eclipse), `⌘ Comma` (Eclipse (macOS)) .     |
| Filter by |  |     > **Note:** > Server side  filtering is only available for the [database objects data](#open_database_object_data), not for the [query results set](#view_query_result_set).      Select a filter that you want to a column.    |
| ![](https://resources.jetbrains.com.cn/help/img/idea/2026.2/app.actions.search.svg) Full-Text Search… | `Ctrl+Alt+Shift+F` (Windows), `⌘ ⌥ ⇧ F` (macOS), `⌘ ⌥ ⇧ F` (IntelliJ IDEA Classic (macOS)), `⌘ ⌥ ⇧ F` (macOS System Shortcuts), `Ctrl+Alt+Shift+F` (XWin), `Ctrl+Alt+Shift+F` (GNOME), `Ctrl+Alt+Shift+F` (KDE), `Ctrl+Alt+Shift+F` (Emacs), `Ctrl+Alt+Shift+F` (Sublime Text), `⌘ ⌥ ⇧ F` (Sublime Text (macOS)), `Ctrl+Alt+Shift+F` (NetBeans), `Ctrl+Alt+Shift+F` (Visual Studio), `⌘ ⌥ ⇧ F` (Visual Studio (macOS)), `Ctrl+Alt+Shift+F` (Eclipse), `⌘ ⌥ ⇧ F` (Eclipse (macOS)) | Open a search window where you can search for data in your database or a group of databases. For more information about full-text search, refer to [Full-text search in databases](full-text-search-for-databases.html).     |
| ![](https://resources.jetbrains.com.cn/help/img/idea/2026.2/app-client.expui.general.download.svg) Export Table to Clipboard |  | Copy the whole table to the clipboard. This action does not depend on Limit page size to setting. |
| Switch Session |  | Open a window to select another session or create a new one. For more information about sessions, refer to [Sessions](managing-connection-sessions.html). |
| Quick Documentation | `Ctrl+Q` (Windows), `F1` (macOS), `⌃ J` (IntelliJ IDEA Classic (macOS)), `⌘ I` (macOS System Shortcuts), `Ctrl+Q` (XWin), `Ctrl+Q` (GNOME), `Ctrl+Q` (KDE), `Ctrl+Q` (Emacs), `Ctrl+Q` (Sublime Text), `Ctrl+Q` (Sublime Text (macOS)), `Ctrl+Q` (NetBeans), `Ctrl+K, I` (Visual Studio), `⌘ K, I` (Visual Studio (macOS)), `Alt+Middle-Click` (Eclipse), `⌥ Middle-Click` (Eclipse (macOS)) | Show information about selected objects. For different database objects, Quick Documentation shows corresponding information. For example, for a group of cells, you will see a summary for the selection. You can preview it in a regular or in a transposed view and also see the related records by their foreign keys.     |

## See also

### Concepts

[Tables](working-with-the-data-editor.html) [Columns](columns.html) [Rows](rows.html) [Cells](cells.html)

### Language and Framework-Specific Guidelines

[Database Tools and SQL](relational-databases.html)

### Reference

[Database tool window](database-tool-window.html)  [Query console reference](query-consoles.html#reference)

