# Find tool window

> **TL;DR**
> `View | Tool Windows | Find`
>
>
>
> `Alt+3` (Windows), `⌘ 3` (macOS), `⌘ 3` (IntelliJ IDEA Classic (macOS)), `⌘ 3` (macOS System Shortcuts), `Alt+3` (XWin), `Alt+3` (GNOME), `Alt+3` (KDE), `Alt+3` (Emacs), `Alt+3` (Sublime Text), `⌘ 3` (Sublime Text (macOS)), `Alt+3` (Xcode), `Alt+3` (Visual Studio), `⌘ 3` (Visual Studio (macOS)), `Alt+3` (ReSharper), `⌘ 3` (ReSharper (macOS)), `Alt+2` (QtCreator), `⌘ 2` (QtCreator (macOS)), `Alt+Shift+U` (NetBeans), `Alt+3` (Eclipse), `⌘ ⌥ Q, S` (Eclipse (macOS))

The Find tool window displays the results of the following searches:

* [Find/Replace in Path](finding-and-replacing-text-in-project.html)

* [Find Usages](find-highlight-usages.html)

* [Refactoring Preview](refactoring-source-code.html)

The results of each search are displayed in a separate tab, or replace the contents of the current tab, depending on the Open in new tab dialog setting. By default, the window appears at the bottom of the screen.

It has a toolbar with a set of buttons, a pane of results, and additional buttons for [Replace in Path](finding-and-replacing-text-in-project.html),  and [Refactoring Preview](refactoring-source-code.html)  operations.

> **Note:**
> Unless you find something, this tool window is not visible in the View menu.

## Toolbar buttons

| Item | Tooltip and Shortcut | Description |
| --- | --- | --- |
|  ![the Settings button](https://resources.jetbrains.com.cn/help/img/idea/2026.2/app.expui.general.settings.svg)  |     Options  `Ctrl+Alt+Shift+F7` (Windows), `⌘ ⌥ ⇧ F7` (macOS), `⌘ ⌥ ⇧ F7` (IntelliJ IDEA Classic (macOS)), `⌃ ⌥ ⇧ U` (macOS System Shortcuts), `Ctrl+Alt+Shift+7` (XWin), `Ctrl+Alt+Shift+7` (GNOME), `Ctrl+Alt+Shift+7` (KDE), `Ctrl+Alt+Shift+F7` (Emacs), `Ctrl+Alt+Shift+F7` (Sublime Text), `⌘ ⌥ ⇧ F7` (Sublime Text (macOS)), `⌘ ⌥ ⇧ F7` (Xcode), `Ctrl+Alt+Shift+F12` (Visual Studio), `⌘ ⌥ ⇧ F12` (Visual Studio (macOS)), `Alt+Shift+F7` (ReSharper), `⌥ ⇧ F17` (ReSharper (macOS)), `Ctrl+Alt+Shift+F7` (QtCreator), `⌘ ⌥ ⇧ F7` (QtCreator (macOS)), `Ctrl+Alt+Shift+F7` (NetBeans), `Ctrl+Alt+Shift+F7` (Eclipse), `⌘ ⌥ ⇧ F7` (Eclipse (macOS))      |   Click this button to open one of the  [Find Usages](null) dialogs, which corresponds to the symbol. You can edit the search settings and click `Rerun` button to execute the modified search query.     |
|  ![the Rerun button](https://resources.jetbrains.com.cn/help/img/idea/2026.2/app.actions.rerun.svg)  |    Rerun     `Ctrl+F5` (Windows), `⌘ R` (macOS), `⌃ F5` (IntelliJ IDEA Classic (macOS)), `⌘ R` (macOS System Shortcuts), `Ctrl+F5` (XWin), `Ctrl+F5` (GNOME), `Ctrl+5` (KDE), `Ctrl+F5` (Emacs), `Ctrl+F5` (Sublime Text), `⌘ R` (Sublime Text (macOS)), `⌘ ⌃ ⌥ G` (Xcode), `Ctrl+Shift+F5` (Visual Studio), `⌥ ⇧ F5` (Visual Studio (macOS)), `Ctrl+Shift+F5` (ReSharper), `⌥ ⇧ F5` (ReSharper (macOS)), `Ctrl+F5` (QtCreator), `Ctrl+F5` (QtCreator (macOS)), `Ctrl+F5` (NetBeans), `Ctrl+F11` (Eclipse), `Ctrl+F5` (Eclipse (macOS))    |  Repeat the last search.   |
|  ![the Close button](https://resources.jetbrains.com.cn/help/img/idea/2026.2/app.expui.general.closeSmall.svg)  | Close     `Ctrl+Shift+F4` (Windows), `⌃ ⇧ F4` (macOS), `⌘ ⇧ F4` (IntelliJ IDEA Classic (macOS)), `⌃ ⇧ F4` (macOS System Shortcuts), `Ctrl+Shift+F4` (XWin), `Ctrl+Shift+F4` (GNOME), `Ctrl+Shift+4` (KDE), `Ctrl+Shift+F4` (Emacs), `Ctrl+Shift+F4` (Sublime Text), `⌃ ⇧ F4` (Sublime Text (macOS)), `⌃ ⇧ F4` (Xcode), `Ctrl+Shift+F4` (Visual Studio), `⌃ ⇧ F4` (Visual Studio (macOS)), `Ctrl+Shift+F4` (ReSharper), `⌃ ⇧ F4` (ReSharper (macOS)), `Ctrl+Shift+F4` (QtCreator), `⌃ ⇧ F4` (QtCreator (macOS)), `Ctrl+Shift+F4` (NetBeans), `Ctrl+W` (Eclipse), `⌘ W` (Eclipse (macOS))   | Close the current tab or the tool window.                 This button is not available in Replace in Path and Refactoring Preview dialogs.   |
|  ![](https://resources.jetbrains.com.cn/help/img/idea/2026.2/app.general.pin_tab.svg)  | Pin Tab |  Click this button to pin or unpin the current tab. You may need to pin a tab to prevent it from closing automatically when the maximum number of tabs is reached in this window.  |
|  ![Expand all](https://resources.jetbrains.com.cn/help/img/idea/2026.2/app.expui.general.expandAll.svg) / ![Collapse all](https://resources.jetbrains.com.cn/help/img/idea/2026.2/app.expui.general.collapseAll.svg)  |    Expand all   `Ctrl+NumPad +` (Windows), `⌘ NumPad +` (macOS), `⌘ NumPad +` (IntelliJ IDEA Classic (macOS)), `⌘ NumPad +` (macOS System Shortcuts), `Ctrl+NumPad +` (XWin), `Ctrl+NumPad +` (GNOME), `Ctrl+NumPad +` (KDE), `Ctrl+NumPad +` (Emacs), `Ctrl+NumPad +` (Sublime Text), `⌘ NumPad +` (Sublime Text (macOS)), `⌘ NumPad +` (Xcode), `Ctrl+NumPad +` (Visual Studio), `⌘ NumPad +` (Visual Studio (macOS)), `Ctrl+NumPad +` (ReSharper), `⌘ NumPad +` (ReSharper (macOS)), `Ctrl+NumPad +` (QtCreator), `Ctrl+NumPad +` (QtCreator (macOS)), `Ctrl+NumPad +` (NetBeans), `Ctrl+Shift+NumPad *` (Eclipse), `⌘ ⇧ NumPad *` (Eclipse (macOS))   Collapse all   `Ctrl+NumPad -` (Windows), `⌘ NumPad -` (macOS), `⌘ NumPad -` (IntelliJ IDEA Classic (macOS)), `⌘ NumPad -` (macOS System Shortcuts), `Ctrl+NumPad -` (XWin), `Ctrl+NumPad -` (GNOME), `Ctrl+NumPad -` (KDE), `Ctrl+NumPad -` (Emacs), `Ctrl+NumPad -` (Sublime Text), `⌘ NumPad -` (Sublime Text (macOS)), `⌘ NumPad -` (Xcode), `Ctrl+NumPad -` (Visual Studio), `⌘ NumPad -` (Visual Studio (macOS)), `Ctrl+NumPad -` (ReSharper), `⌘ NumPad -` (ReSharper (macOS)), `Ctrl+NumPad -` (QtCreator), `Ctrl+NumPad -` (QtCreator (macOS)), `Ctrl+NumPad -` (NetBeans), `Ctrl+Shift+NumPad /` (Eclipse), `⌘ ⇧ NumPad /` (Eclipse (macOS))  |  Use these buttons to have all nodes expanded or collapsed.  |
|  ![Previous occurrence](https://resources.jetbrains.com.cn/help/img/idea/2026.2/app.expui.general.up.svg)/![Next occurrence](https://resources.jetbrains.com.cn/help/img/idea/2026.2/app.expui.general.down.svg)  |    Previous/next occurrence     `Ctrl+Alt+Up` (Windows), `⌘ ⌥ ↑` (macOS), `⌘ ⌥ ↑` (IntelliJ IDEA Classic (macOS)), `⌘ ⌥ ↑` (macOS System Shortcuts), `Ctrl+Alt+Up` (XWin), `Alt+Shift+Up` (GNOME), `Ctrl+Alt+Up` (KDE), `Ctrl+Alt+Up` (Emacs), `Ctrl+Alt+Up` (Sublime Text), `Ctrl+Alt+Up` (Sublime Text (macOS)), `⌃ ↑` (Xcode), `Ctrl+Alt+Up` (Visual Studio), `⌘ ⌥ ↑` (Visual Studio (macOS)), `Ctrl+Alt+Up` (ReSharper), `⌘ ⌥ ↑` (ReSharper (macOS)), `Ctrl+Alt+Up` (QtCreator), `⌘ ⌥ ↑` (QtCreator (macOS)), `Ctrl+Alt+Up` (NetBeans), `Ctrl+Alt+Up` (Eclipse), `Ctrl+Alt+Up` (Eclipse (macOS))  `Ctrl+Alt+Down` (Windows), `⌘ ⌥ ↓` (macOS), `⌘ ⌥ ↓` (IntelliJ IDEA Classic (macOS)), `⌘ ⌥ ↓` (macOS System Shortcuts), `Ctrl+Alt+Down` (XWin), `Alt+Shift+Down` (GNOME), `Ctrl+Alt+Down` (KDE), `Ctrl+Alt+Down` (Emacs), `Ctrl+Alt+Down` (Sublime Text), `Ctrl+Alt+Down` (Sublime Text (macOS)), `⌃ ↓` (Xcode), `Ctrl+Alt+Down` (Visual Studio), `⌘ ⌥ ↓` (Visual Studio (macOS)), `Ctrl+Alt+Down` (ReSharper), `⌘ ⌥ ↓` (ReSharper (macOS)), `Ctrl+Alt+Down` (QtCreator), `Ctrl+Alt+Down` (QtCreator (macOS)), `Ctrl+Alt+Down` (NetBeans), `Ctrl+Alt+Down` (Eclipse), `Ctrl+Alt+Down` (Eclipse (macOS))   | Navigate to the previous/next element in the tab of results. |
|  ![the Help icon](https://resources.jetbrains.com.cn/help/img/idea/2026.2/app.actions.help.svg)  |    Help   `F1` (Windows), `⌘ ⇧ F1` (macOS), `F1` (IntelliJ IDEA Classic (macOS)), `⌘ ⇧ F1` (macOS System Shortcuts), `F1` (XWin), `F1` (GNOME), `F1` (KDE), `F1` (Emacs), `F1` (Sublime Text), `⌘ ⇧ F1` (Sublime Text (macOS)), `⌘ ⇧ F1` (Xcode), `F1` (Visual Studio), `F1` (Visual Studio (macOS)), `F1` (ReSharper), `F1` (ReSharper (macOS)), `F1` (QtCreator), `F1` (QtCreator (macOS)), `F1` (NetBeans), `F1` (Eclipse), `⌘ ⇧ F1` (Eclipse (macOS))  | Open a browser and show the corresponding help page. |
|  ![Group by](https://resources.jetbrains.com.cn/help/img/idea/2026.2/app.actions.groupBy_dark.svg)  | Group by |    Click this icon to open the menu for the following grouping options:        * File Structure `Ctrl+S` (Windows), `Ctrl+S` (macOS), `Ctrl+S` (IntelliJ IDEA Classic (macOS)), `Ctrl+S` (macOS System Shortcuts), `Ctrl+S` (XWin), `Ctrl+S` (GNOME), `Ctrl+S` (KDE), `Ctrl+S` (Emacs), `Ctrl+S` (Sublime Text), `Ctrl+S` (Sublime Text (macOS)), `Ctrl+S` (Xcode), `Ctrl+S` (Visual Studio), `Ctrl+S` (Visual Studio (macOS)), `Ctrl+S` (ReSharper), `Ctrl+S` (ReSharper (macOS)), `Ctrl+S` (QtCreator), `Ctrl+S` (QtCreator (macOS)), `Ctrl+S` (NetBeans), `Ctrl+S` (Eclipse), `Ctrl+S` (Eclipse (macOS)): select this option to display the found usages under the corresponding method nodes.    * Module `Ctrl+Alt+M` (Windows), `⌃ M` (macOS), `⌃ M` (IntelliJ IDEA Classic (macOS)), `⌃ M` (macOS System Shortcuts), `Ctrl+Alt+M` (XWin), `Ctrl+Alt+M` (GNOME), `Ctrl+Alt+M` (KDE), `Ctrl+Alt+M` (Emacs), `Ctrl+Alt+M` (Sublime Text), `⌃ M` (Sublime Text (macOS)), `⌃ M` (Xcode), `Ctrl+Alt+M` (Visual Studio), `⌃ M` (Visual Studio (macOS)), `Ctrl+Alt+M` (ReSharper), `⌃ M` (ReSharper (macOS)), `Ctrl+Alt+M` (QtCreator), `Ctrl+Alt+M` (QtCreator (macOS)), `Ctrl+Alt+M` (NetBeans), `Ctrl+Alt+M` (Eclipse), `⌃ M` (Eclipse (macOS)): if you select this option, the found usages will show under the corresponding module or the library node. > **Tip:** > This type of grouping is helpful, when a package is split between several modules.    * Flatten Modules`Alt+O` (Windows), `⌃ O` (macOS), `⌃ O` (IntelliJ IDEA Classic (macOS)), `⌃ O` (macOS System Shortcuts), `Alt+O` (XWin), `Alt+O` (GNOME), `Alt+O` (KDE), `Alt+O` (Emacs), `Alt+O` (Sublime Text), `⌃ O` (Sublime Text (macOS)), `Alt+O` (Xcode), `Alt+O` (Visual Studio), `⌃ O` (Visual Studio (macOS)), `Alt+O` (ReSharper), `⌃ O` (ReSharper (macOS)), `Alt+O` (QtCreator), `Alt+O` (QtCreator (macOS)), `Alt+O` (NetBeans), `Alt+O` (Eclipse), `⌃ O` (Eclipse (macOS)): select this option to display all the modules as a single-level tree view.    * Package `Ctrl+P` (Windows), `Ctrl+P` (macOS), `Ctrl+P` (IntelliJ IDEA Classic (macOS)), `Ctrl+P` (macOS System Shortcuts), `Ctrl+P` (XWin), `Ctrl+P` (GNOME), `Ctrl+P` (KDE), `Ctrl+P` (Emacs), `Ctrl+P` (Sublime Text), `Ctrl+P` (Sublime Text (macOS)), `Ctrl+P` (Xcode), `Ctrl+P` (Visual Studio), `Ctrl+P` (Visual Studio (macOS)), `Ctrl+P` (ReSharper), `Ctrl+P` (ReSharper (macOS)), `Ctrl+P` (QtCreator), `Ctrl+P` (QtCreator (macOS)), `Ctrl+P` (NetBeans), `Ctrl+P` (Eclipse), `Ctrl+P` (Eclipse (macOS)): select this option to display all the found usages under their respective packages.    * Test/Production: select this option to group the usages according the Production and Test scopes.    * Usage type `Ctrl+T` (Windows), `Ctrl+T` (macOS), `Ctrl+T` (IntelliJ IDEA Classic (macOS)), `Ctrl+T` (macOS System Shortcuts), `Ctrl+T` (XWin), `Ctrl+T` (GNOME), `Ctrl+T` (KDE), `Ctrl+T` (Emacs), `Ctrl+T` (Sublime Text), `Ctrl+T` (Sublime Text (macOS)), `Ctrl+T` (Xcode), `Ctrl+T` (Visual Studio), `Ctrl+T` (Visual Studio (macOS)), `Ctrl+T` (ReSharper), `Ctrl+T` (ReSharper (macOS)), `Ctrl+T` (QtCreator), `Ctrl+T` (QtCreator (macOS)), `Ctrl+T` (NetBeans), `Ctrl+T` (Eclipse), `Ctrl+T` (Eclipse (macOS)): if this option is selected, the search results are grouped by the following categories:    * Merge Usages from the Same Line: select this option to merge the duplicate usages found on the same line.    |
| ![Show read access](https://resources.jetbrains.com.cn/help/img/idea/2026.2/app.actions.showReadAccess.svg)  | Show read access  `Ctrl+R` (Windows), `⌘ R` (macOS), `⌘ R` (IntelliJ IDEA Classic (macOS)), `⌘ R` (macOS System Shortcuts), `Ctrl+R` (XWin), `Ctrl+R` (GNOME), `Ctrl+R` (KDE), `Alt+Shift+5` (Emacs), `Ctrl+H` (Sublime Text), `⌘ ⌥ F` (Sublime Text (macOS)), `⌘ ⌥ F` (Xcode), `Ctrl+H` (Visual Studio), `⌃ H` (Visual Studio (macOS)), `Ctrl+H` (ReSharper), `⌃ H` (ReSharper (macOS)), `Ctrl+R` (QtCreator), `Ctrl+R` (QtCreator (macOS)), `Ctrl+H` (NetBeans), `Ctrl+F` (Eclipse), `Ctrl+R` (Eclipse (macOS))   | This button is available for [Find Usages](null) only.      If this button is pressed, the search results include references to the read access methods.    |
|  ![Show write access](https://resources.jetbrains.com.cn/help/img/idea/2026.2/app.actions.showWriteAccess.svg)  | Show write access   `Ctrl+W` (Windows), `⌥ ↑` (macOS), `⌘ W` (IntelliJ IDEA Classic (macOS)), `⌥ ↑` (macOS System Shortcuts), `Ctrl+W` (XWin), `Ctrl+W` (GNOME), `Ctrl+W` (KDE), `Ctrl+Alt+W` (Emacs), `Ctrl+Shift+Space` (Sublime Text), `⌘ ⇧ A` (Sublime Text (macOS)), `⌘ ⌥ ↑` (Xcode), `Alt+Shift+=` (Visual Studio), `⌘ ⌥ →` (Visual Studio (macOS)), `Ctrl+W` (ReSharper), `⌥ ↑` (ReSharper (macOS)), `Ctrl+U` (QtCreator), `⌘ U` (QtCreator (macOS)), `Alt+Shift+.` (NetBeans), `Alt+Shift+Up` (Eclipse), `⌃ ⇧ ↑` (Eclipse (macOS)) | This button is available for [Find Usages](null)  only.      If this button is pressed, the search results include references to the write access methods.    |
|  ![Show import statements](https://resources.jetbrains.com.cn/help/img/idea/2026.2/app.actions.showImportStatements.svg)  | Show import statements   `Ctrl+I` (Windows), `⌃ I` (macOS), `⌘ I` (IntelliJ IDEA Classic (macOS)), `⌃ ⇧ I` (macOS System Shortcuts), `Ctrl+I` (XWin), `Ctrl+I` (GNOME), `Ctrl+I` (KDE), `Ctrl+I` (Emacs), `Ctrl+I` (Sublime Text), `Ctrl+I` (Sublime Text (macOS)), `⌘ ⌃ I` (Xcode), `Ctrl+Shift+I` (Visual Studio), `⌃ I` (Visual Studio (macOS)), `Ctrl+I` (ReSharper), `⌃ I` (ReSharper (macOS)), `Ctrl+I` (QtCreator), `⌃ I` (QtCreator (macOS)), `Ctrl+I` (NetBeans), `Alt+Shift+P` (Eclipse), `Ctrl+I` (Eclipse (macOS))   | This button is available for [Find Usages](null)  only.       If this button is pressed, the search results include the usages in the import statements.     |
|  ![the Preview Usages button](https://resources.jetbrains.com.cn/help/img/idea/2026.2/app.actions.previewDetails.svg)  | Preview Usages |   Click this icon to open the Preview pane next to the search results.  |

## Context menu commands

| Item | Shortcut | Description |
| --- | --- | --- |
|  Rerun  |  `Ctrl+F5` (Windows), `⌘ R` (macOS), `⌃ F5` (IntelliJ IDEA Classic (macOS)), `⌘ R` (macOS System Shortcuts), `Ctrl+F5` (XWin), `Ctrl+F5` (GNOME), `Ctrl+5` (KDE), `Ctrl+F5` (Emacs), `Ctrl+F5` (Sublime Text), `⌘ R` (Sublime Text (macOS)), `⌘ ⌃ ⌥ G` (Xcode), `Ctrl+Shift+F5` (Visual Studio), `⌥ ⇧ F5` (Visual Studio (macOS)), `Ctrl+Shift+F5` (ReSharper), `⌥ ⇧ F5` (ReSharper (macOS)), `Ctrl+F5` (QtCreator), `Ctrl+F5` (QtCreator (macOS)), `Ctrl+F5` (NetBeans), `Ctrl+F11` (Eclipse), `Ctrl+F5` (Eclipse (macOS))  | Run the action again and show the results on the same tab. |
| Jump to Source |  `F4` (Windows), `⌘ ↓` (macOS), `F4` (IntelliJ IDEA Classic (macOS)), `F4` (macOS System Shortcuts), `F4` (XWin), `F4` (GNOME), `F4` (KDE), `F4` (Emacs), `F4` (Sublime Text), `F4` (Sublime Text (macOS)), `⌘ ↓` (Xcode), `F4` (Visual Studio), `⌘ ↓` (Visual Studio (macOS)), `F4` (ReSharper), `⌘ ↓` (ReSharper (macOS)), `F4` (QtCreator), `F4` (QtCreator (macOS)), `F4` (NetBeans), `F12` (Eclipse), `F3` (Eclipse (macOS))  | Navigate to the selected item in the source code. |
| Include |  `Insert` (Windows), `⇧ ⌫` (macOS), `Insert` (IntelliJ IDEA Classic (macOS)), `⇧ ⌫` (macOS System Shortcuts), `Insert` (XWin), `Insert` (GNOME), `Insert` (KDE), `Insert` (Emacs), `Insert` (Sublime Text), `⇧ ⌫` (Sublime Text (macOS)), `⇧ ⌫` (Xcode), `Insert` (Visual Studio), `⇧ ⌫` (Visual Studio (macOS)), `Insert` (ReSharper), `⇧ ⌫` (ReSharper (macOS)), `Insert` (QtCreator), `⇧ ⌫` (QtCreator (macOS)), `Insert` (NetBeans), `Insert` (Eclipse), `⇧ ⌫` (Eclipse (macOS))  | For an [excluded item](#ex): include the item in the list of results.  |
| Exclude | `Delete` (Windows), `⌦` (macOS), `⌦` (IntelliJ IDEA Classic (macOS)), `⌦` (macOS System Shortcuts), `Delete` (XWin), `Delete` (GNOME), `Delete` (KDE), `Delete` (Emacs), `Delete` (Sublime Text), `⌦` (Sublime Text (macOS)), `⌫` (Xcode), `Delete` (Visual Studio), `⌦` (Visual Studio (macOS)), `Delete` (ReSharper), `⌦` (ReSharper (macOS)), `Delete` (QtCreator), `⌦` (QtCreator (macOS)), `Delete` (NetBeans), `Delete` (Eclipse), `⌦` (Eclipse (macOS)) |    Exclude the selected item from the list of results. (Excluded items are shown strikethrough.)       When you carry out the Replace All or the Do Refactor command, the excluded items are not affected.    |
| Remove | `Ctrl+X` (Windows), `⌘ X` (macOS), `⌘ X` (IntelliJ IDEA Classic (macOS)), `⌘ X` (macOS System Shortcuts), `Ctrl+X` (XWin), `Ctrl+X` (GNOME), `Ctrl+X` (KDE), `Shift+Delete` (Emacs), `Ctrl+X` (Sublime Text), `⌘ X` (Sublime Text (macOS)), `⌘ X` (Xcode), `Ctrl+X` (Visual Studio), `⌘ X` (Visual Studio (macOS)), `Ctrl+X` (ReSharper), `⌘ X` (ReSharper (macOS)), `Ctrl+X` (QtCreator), `⌘ X` (QtCreator (macOS)), `Ctrl+X` (NetBeans), `Ctrl+X` (Eclipse), `⌘ X` (Eclipse (macOS))  | Remove the selected item from the list of results. |
|  Recent Find Usages | `Alt+Down` (Windows), `⌥ ↓` (macOS), `⌥ ↓` (IntelliJ IDEA Classic (macOS)), `⌥ ↓` (macOS System Shortcuts), `Alt+Down` (XWin), `Alt+Down` (GNOME), `Alt+Down` (KDE), `Alt+Down` (Emacs), `Alt+Down` (Sublime Text), `⌥ ↓` (Sublime Text (macOS)), `⌥ ↓` (Xcode), `Alt+Down` (Visual Studio), `⌥ ↓` (Visual Studio (macOS)), `Alt+Down` (ReSharper), `⌥ ↓` (ReSharper (macOS)), `Alt+Down` (QtCreator), `⌥ ↓` (QtCreator (macOS)), `Alt+Down` (NetBeans), `Alt+Down` (Eclipse), `⌥ ↓` (Eclipse (macOS)) | Show the list of recent searches. Select an item in the list to see the search results. |
| Export to Text File | `Alt+O` (Windows), `⌃ O` (macOS), `⌃ O` (IntelliJ IDEA Classic (macOS)), `⌃ O` (macOS System Shortcuts), `Alt+O` (XWin), `Alt+O` (GNOME), `Alt+O` (KDE), `Alt+O` (Emacs), `Alt+O` (Sublime Text), `⌃ O` (Sublime Text (macOS)), `Alt+O` (Xcode), `Alt+O` (Visual Studio), `⌃ O` (Visual Studio (macOS)), `Alt+O` (ReSharper), `⌃ O` (ReSharper (macOS)), `Alt+O` (QtCreator), `Alt+O` (QtCreator (macOS)), `Alt+O` (NetBeans), `Alt+O` (Eclipse), `⌃ O` (Eclipse (macOS)) | Save the contents of the current result tab. In the Export preview dialog, specify the target file or copy information to the clipboard. Before saving, you can also modify the information to be saved. |

### Upper Toolbar buttons

| Icon | Tooltip | Description |
| --- | --- | --- |
| ![Show Options Menu](https://resources.jetbrains.com.cn/help/img/idea/2026.2/app.expui.general.settings.svg) | Show Options Menu | Click this icon to open a menu with more options for managing the tool window such as displaying or hiding side toolbars, group tabs, selecting viewing mode, resizing, and so on.  |
| ![Hide](https://resources.jetbrains.com.cn/help/img/idea/2026.2/app.general.hideToolWindow.svg) | Hide | Hides the tool window. Press `Alt+3` (Windows), `⌘ 3` (macOS), `⌘ 3` (IntelliJ IDEA Classic (macOS)), `⌘ 3` (macOS System Shortcuts), `Alt+3` (XWin), `Alt+3` (GNOME), `Alt+3` (KDE), `Alt+3` (Emacs), `Alt+3` (Sublime Text), `⌘ 3` (Sublime Text (macOS)), `Alt+3` (Xcode), `Alt+3` (Visual Studio), `⌘ 3` (Visual Studio (macOS)), `Alt+3` (ReSharper), `⌘ 3` (ReSharper (macOS)), `Alt+2` (QtCreator), `⌘ 2` (QtCreator (macOS)), `Alt+Shift+U` (NetBeans), `Alt+3` (Eclipse), `⌘ ⌥ Q, S` (Eclipse (macOS)) to restore it.  |

## See also

### Getting Started

[Tool windows](tool-windows.html)

### Procedures

[Find and replace in project](finding-and-replacing-text-in-project.html)    [Refactoring](refactoring-source-code.html)

### External Links

[JetBrains CLion Blog](http://blog.jetbrains.com/clion/)

